Page 1 of 2

[known issue] Small missile glitch

Posted: 06 Nov 2015, 02:22
by Tamurel
I noticed once that my hud showed I had atlasses, but for some reason I couldn't select them. Wasn't able to reproduce the issue, and I'm not sure if I actually had atlasses or if the hud erroneously showed me I did.

Re: Small missile glitch

Posted: 06 Nov 2015, 13:25
by MadMax1998
This problem has haunted us a bit on Hawk's server, where he (as the admin) and we (as clients) encountered it (rarely). It could never be reproduced on another server though. It's a cosmetic problem only; meaning it won't affect the function of the missiles (as you pick up new ones, the HUD will update and you will also be able to use them.

Re: Small missile glitch

Posted: 07 Nov 2015, 00:33
by Dusty267
Also noticed that if you back into a wall completely, (and held down the reverse key), when you shoot a dumbfire it doesn't actually shoot, but you lose the missile....

Missile Glitches

Posted: 07 Nov 2015, 02:00
by Dusty267
I found a couple issues on Vertigo regarding missiles in general.

First, I shot all my Atlas missiles, and after I hit 0, it did not switch missiles, even after clicking my mouse to shoot a missile. This would render anyone shooting atlas missiles without missiles all of a sudden in a fight...
(I have photos but I don't know how to upload them in a thread..)

Second, after I depleted my Atlas missile storage and (manually) switched to another, my HUD was showing me I had some still. Scrolling through just skipped it, (like it should do). The HUD just displayed it wrong. Will test with the other secondaries.

Re: Missile Glitches

Posted: 07 Nov 2015, 02:07
by Dusty267
Same thing with the Seekers. Once I run out of Seekers, the next time I (try) to fire a missile it will not auto-switch for me. (Yes, I have some dumbfires, I'm not completely empty) :) So auto-switching on missile depletion is a yes.

I tested again and it did auto-switch. Must be a little hiccup. (Still cripples fights though).

Re: Missile Glitches

Posted: 07 Nov 2015, 03:17
by NUMBERZero
Yep, I'm getting this too with the Atlas and Seekers.

Re: Missile Glitches

Posted: 07 Nov 2015, 05:34
by Dusty267
Also noticed, sometimes I click once to shoot one missile, and two get shot. (With the normal delay/reload time). So it just thinks I clicked twice, but I only clicked once. This is pretty rare and might be my end.

Re: Missile Glitches

Posted: 07 Nov 2015, 06:05
by 1/2Hawk
^ This one sounds like a problem with a high ping to the server...

Re: Missile Glitches

Posted: 07 Nov 2015, 06:21
by Dusty267
Ok. I also found out that when someone does by an Atlas missile, there is no explosion. They just....disappear. Same when I got nailed. No fancy explosion, just a little hiccup and then I see the death screen.

Re: [known issue] Small missile glitch

Posted: 08 Nov 2015, 16:22
by MadMax1998
Dusty, this is apparently caused the the "bounding box" around the ship being too small, so it backs your missile launcher into the wall. We can increase the size of the box in the next update, but it will of course make navigation a bit different as you will not be able to hug walls as much as before.