Page 1 of 1

[not serious] Invulnerability flashes when you enter...

Posted: 17 Dec 2015, 21:29
by Whiteshark
I could see invulnerability quickly flashing away when I entered the are in vertigo for the first time in my hosted game. :D I wonder what you've done to it, but please just keep it hidden.

Invulnerability flashes when you enter...

Posted: 17 Dec 2015, 21:29
by Whiteshark
I could see invulnerability quickly flashing away when I entered the are in vertigo for the first time in my hosted game. :D I wonder what you've done to it, but please just keep it hidden.

Re: Invulnerability flashes when you enter...

Posted: 17 Dec 2015, 21:30
by Whiteshark
Update. If you're fast you can also pick it! Not great!

Re: Invulnerability flashes when you enter...

Posted: 17 Dec 2015, 23:11
by 1/2Hawk
Per suggestions here, we made the invul and cloak availability to now be based on player count. For R4 we're trying 3 players for the cloak and 5 for the invul. (FYI) These will appear and disappear during a round as people join/leave - that's normal.

Because the game needs a few seconds to get everybody loaded in, there's a 5-sec delay before counting heads the first time which is why it flashes away. In most maps, these are not located near player spawns but in Vertigo there's really nowhere you cant fly to get to it in that time unless we spawn everybody in the energy center. Attempted to have it just start 'off' at the beginning, but that caused issues. If it doesn't load in as part of the nav system on begin play then it doesn't want to work right once its available later. So the alternative was to have the game pick it up like a player would and hide it that way.

I'm sure this could be fixed with help from Max but honestly I'd rather say Lucky You! to anybody who gets it on round start and focus on fixing other issues first.