Page 1 of 1

[R3] Game shuts down when main menu appears

Posted: 06 Nov 2015, 10:49
by Tamurel
As the title says, the game shuts down when the main menu appears. Had this problem, then figured I'd update to R2 first before posting, but problem persists. I have made sure to put my beta key ini file into the udkgame/config folder, so that's not the problem. As for reproducability, it currently happens everytime I launch the game. Yesterday I could play just fine, so the only difference between then and now is that I rebooted my pc.

Re: Game shuts down when main menu appears

Posted: 06 Nov 2015, 10:56
by Tamurel
Nevermind, I forgot to start steam before launching the game =/ Silly me

Re: [solved] Game shuts down when main menu appears

Posted: 18 Nov 2015, 09:22
by STealTH

I'm getting this again in R3 now.

I had deleted R2 and all files related to it.
Also deleted the Unreal Engine stuff in from add/remove programs.

Restarted PC.

Reinstalled and also linked UDK to Steam.
Copied my key file to the Solc/UDKGame/Config directory.

Started game, gets to menu, leaves game.

I have noticed that in Copying my Key file to the Solc/UDKGame/Config directory, it copies properly and I refresh to check again. I open the file and it has my key as it should.

I run the game, gets to menu, leaves game, and I check in Solc/UDKGame/Config directory again in my UDKUserKey file. My key content/text is suddenly removed from the file every time the game closes.

Restarted PC again, to check if Steam just needs to reload with it on, no difference.

Edit 01: In checking again, the executable UDK file won't save into the games list and the game can't be run through Steam..
Edit 02: Without having made any changes whatsoever, not checking to add the executable file again or anything.. Steam now runs the game after 6 fails.
Edit 03: The game still closes upon reaching the menu screen and the UDKUserKey file keeps deleting its own content (my key) after each time the game closes.
Edit 04: Deleted all files mentioned in R3 Readme file and UDKUserKey again. Pasted UDKUserKey (has my key in it) and started game again. No change, exits in menu and deletes file's key content.

Any ideas?


Re: [solved] Game shuts down when main menu appears

Posted: 18 Nov 2015, 14:06
by MadMax1998
While this is unusual, the problem could be related to the engine seeing your old key file as "outdated" and replacing it with the "newer" version which is DefaultUserKey.ini that came with R3, and is of course newer. Try restoring your own UDKUserKey.ini from your e-mail, open it and save it to give it a newer timestamp. Then try starting the game again.

Alternatively, you can delete UDKUserKey.ini again after putting its contents into DefaultUserKey.ini (this works, but is of course not the proper way to store a user key). Then the game MUST resort to the key stored in DefaultUserKey.ini, which is yours.

Re: [R3] Game shuts down when main menu appears

Posted: 18 Nov 2015, 22:14
by DuderSeb
I had this issue too. I solved it by opening R3's vanilla UDKUserKey.ini with a text editor and pasting my key in the blank.

In retrospect, perhaps write-protecting your UDKUserKey.ini before copying it in oughta prevent this (?)

Re: [R3] Game shuts down when main menu appears

Posted: 19 Nov 2015, 00:02
by STealTH
1. Replacing the file does not work.
2. Copying the key and pasting it into the default file works.

I don't know how this makes sense.
If a file won't be accepted, the content shouldn't either I thought.

I have previously thought of doing this but thought it was too illogical.
Thanks for suggesting it :)

Re: [R3] Game shuts down when main menu appears

Posted: 19 Nov 2015, 11:52
by MadMax1998
The problem boils down to timestamps on the config files. UDK uses timestamps on files to verify if a file is current or out of date. Usually that comes into play when we develop the game and someone has an older content or code package, and then they can't play with someone else (kinda like when you guys are not on the current build and can't join a server). It's all based on file dates and times.
My guess is that the UDKUserKey.ini is overwritten by DefaultUserKey.ini's content (empty) because UDKUserKey.ini came from before R3, and is hence older than the build itself, making the engine think it's outdated and replacing it. Replacing/regenerating the UDK* ini files from the Default* ini files is how the engine works in general. Default* files store what we want the game to start with, and UDK* files store what you changed as a user. That's why you usually should not edit any Default* ini files.

What Seb suggested was essentially what I suggested: open UDKUserKey.ini and resave it (Seb's method results in the same thing). That gives it a new, current timestamp, and will make UDK accept the file as current, and read the key from it on startup.
The other method, which you had success with, instead forces UDK to read the key from the Default* file (since, as I said, Default* is always used to generate the UDK* files and thus always takes precendence if the UDK* file doesn't check out).

The thing is that this never happened in R2, and it also didn't happen for me. I just pasted my key file into my own R3 build and the game accepted it. Not sure if anyone else had the issue...?