Mouse buttons ignored in config screen

Please report any bugs you find here. The more detailed your description, the better. Make sure you read the list of known issues inside before making a report.

Moderator: SolC Development Leads

User avatar
Mobius
Posts: 3
Joined: 16 Apr 2016, 04:28
Location: Christchurch, New Zealand
Contact:

Mouse buttons ignored in config screen

Postby Mobius » 16 Apr 2016, 05:51

I have three mice installed. A Logitech MX Revolution, a MadCatz RAT7 and a microsoft mouse embedded in the handle of my Logitech 3D Pro for More stick buttons :)

In the config section for mouse buttons, I want to use Mouse 1 (Left Mouse) as my Secondary Fire button, but I can't get any of the buttons on any of the mices to trigger the config - it just says "waiting".

Is it doing this because I configured a Joystick button as Primary Fire?
How many escape pods are there? "NONE, SIR!" You counted them? "TWICE, SIR!"
User avatar
MadMax1998
Site Admin
Posts: 1550
Joined: 07 Nov 2012, 13:43
Location: Berlin, Germany
Contact:

Re: Mouse buttons ignored in config screen

Postby MadMax1998 » 16 Apr 2016, 17:41

The engine only supports one mouse, and that would be one using a standard Windows driver or compatible (read: no special third-party drivers that handle the buttons differently from Windows).

Try using a different mouse *or* turning off any mouse customization software.

BTW, you can totally use your joystick for firing too; a stick can be bound to the same function like a mouse.
Max
Sol Contingency Programming Lead
Sol Contingency Website

Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 1 guest