Logitech Extreme 3D Pro Controls Fix

For technical problems with the build. Not for bug reports!

Moderator: SolC Development Leads

Post Reply
STealTH
Beta Tester
Posts: 66
Joined: 14 Dec 2013, 16:50
Location: New Zealand

Logitech Extreme 3D Pro Controls Fix

Post by STealTH » 08 Nov 2015, 03:27

Firstly, I would like to acknowledge SgtThorn's assistance in this matter. He walked me through the temporary fix for this situation with the Logitech Extreme 3D Pro. Thank you so much man!

Situation:
Right X keeps getting auto selected and saved in joystick settings in-game, regardless of what key/input you press. If you have also tried every other combination of settings to get this going, including deleting your *.ini files and setting every ToggleOneWay* and ToggleNegOneWay*, but nothing works, then you may wish to try this (no need to delete config files again or do toggles):

Solution and getting Started:
1. Download the X360 wrapper on: http://www.x360ce.com/
2. Copy X360.exe into your SolC/Binaries/Win32 directory.
2. Check all settings in X360 wrapper are as default.
3. Check all your Joystick functions work in X360/Windows settings.

Setting controls in X360 Wrapper:
1. Click on the "Controller 1" tab if you are not already there.
2. Clear every single function already set in "stick Axis Y/X, etc" drop down menus.
3. Clear every single function already set in all "button" drop down menus.
4. On the left hand side of the gamepad picture click "Stick Axis X" then hit "Record" and move the stick left/Right.
5. On the left hand side of the gamepad picture click "Stick Axis Y" then hit "Record" and move the stick Up/Down.
6. On the right hand side of the gamepad picture click "Stick Axis X" then hit "Record" and move your Rudder.
7. On the right hand side of the gamepad picture click "Y Button" and click your primary fire button on the joystick.
8. On the right hand side of the gamepad picture click "X Button" and click your Secondary fire button on the joystick.
9. Close X360 as it doesn't need to be running while the game is up.

Setting up controls in game:
1. Hit "Options" -> "Input" -> "Keys/Flightstick"
2. Hit the "Customize Keyboard/Keys" menu and set up your keys.
3. Hit the "Customize Stick/gamepad/Axes" menu and set up your axes.
4. Exit menus / join a game!

As noted before, this is a temporary fix. For a permanent one, the team is working on that.

Enjoy :)

STealTH
Last edited by STealTH on 09 Nov 2015, 03:57, edited 1 time in total.

User avatar
Dusty267
Beta Tester
Posts: 96
Joined: 24 Feb 2015, 00:23

Re: Logitech Extreme 3D Pro Controls Fix

Post by Dusty267 » 08 Nov 2015, 04:41

32 or 64 bit? I'm gonna try it! Thanks!

STealTH
Beta Tester
Posts: 66
Joined: 14 Dec 2013, 16:50
Location: New Zealand

Re: Logitech Extreme 3D Pro Controls Fix

Post by STealTH » 08 Nov 2015, 08:03

I used 32bit because I'm on Windows 8.1 32bit :).
I have noticed lag though, with the joystick. I click fire, and it fires .5-1 second later, and it's the same with other functions.
I bet it's because of the wrapper. I bought a new joystick for this but recommend a mouse for now hehe.

But I will also say.. I almost can't believe how good the mouse feels in this game.
It's nothing like D1/D2 for me and feels much much better than those.
Nice work on the mouse controls. Just have to learn how to play all over again now.

On the hand, changing to the mouse I turned up the sensitivity to be on equal footing with mousers, don't want them to have a targeting advantage there when I'm on the joystick hehe. Yaw and pitch seemed a bit too sensitive with the joystick and it was hard to control. I now wonder the nature of this is just that D chose the joystick and we chose the mouse, and we can't have it both ways? Few played D with a mouse. I remember watching a video of Birdseye targeting and shooting with a mouse. That guy did the impossible and did it perfectly. Aside from that, there was one other good player that used a mouse between 1994-1997, I forget the name. D1/D2 made it so the sensitivity was maxed at the rate of the joystick, not the other way around. When using a mouse you had to move the mouse, lift it up off desk, back to the original position and move it some more to face the ship the other direction.

In any case, joystick functions haven't been fully implemented here yet. The team will take the best path, whatever that is. We also want more people playing the game.

User avatar
Dusty267
Beta Tester
Posts: 96
Joined: 24 Feb 2015, 00:23

Re: Logitech Extreme 3D Pro Controls Fix

Post by Dusty267 » 08 Nov 2015, 15:16

I actually agree with the mouse part. I does seem to work better. (Besides the turning around part). And I do find that I am actually more accurate than when I use my joy.... thanks for the possible fix though!

User avatar
MadMax1998
Site Admin
Posts: 1556
Joined: 07 Nov 2012, 13:43
Location: Berlin, Germany
Contact:

Re: Logitech Extreme 3D Pro Controls Fix

Post by MadMax1998 » 08 Nov 2015, 16:44

But I will also say.. I almost can't believe how good the mouse feels in this game.
I am a mouser exclusively and I wrote the flight code. ;)

That said, joystick controls are easily set up with sensitivity and deadzone settings so you can make them respond as you want. I don't think there is a magic formula for inputs; the engine takes your axis between a range from -1 to +1 and applies it to ship rotation. If you feel that's overly sensitive, you can turn down joy sensitivity (but it will make your max turn speed SLOWER!).
Max
Sol Contingency Programming Lead
Sol Contingency Website

MaxT
Beta Tester
Posts: 26
Joined: 18 May 2013, 20:47

Re: Logitech Extreme 3D Pro Controls Fix

Post by MaxT » 12 Nov 2015, 06:08

In addition to the guide in 1st post, if the wrapper is not working for you in game, make sure than your joystick shows up as the first controller in the configuration utility. I had to disable my Razer Orbweaver (wasn't even using it), since it was showing up as Controller 1 and my actual joystick was showing up as controller 2.

Combining them might work as well, I haven't tried.

SgtThorne
Beta Tester
Posts: 61
Joined: 14 Oct 2014, 10:45

Re: Logitech Extreme 3D Pro Controls Fix

Post by SgtThorne » 15 Nov 2015, 16:29

Dusty267 wrote:32 or 64 bit? I'm gonna try it! Thanks!
FYI I'm on Windows 7 64-bit, and the 64-bit version wouldn't work. I use the 32-bit version (I note UDK is 32 bit).
Running: Windows 7 Ultimate 64-bit SP1
Intel Core i7 4770K @ 4.20GHz Haswell - 16.0GB Dual-Channel DDR3
EVGA GeForce GTX 960 SSC 4GB - NVIDIA Drivers v10.18.13.5850
Asus Z87-PRO Motherboard - Onboard High Definition Audio

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests